Loctax - App is down – Incident details

App is down

Resolved
Major outage
Started 5 months agoLasted 19 minutes

Affected

App

Major outage from 9:30 AM to 9:48 AM

Updates
  • Resolved
    Resolved

    This incident has been resolved. A hard refresh of the app might be needed.

  • Identified
    Identified

    We already have identified a fix and are deploying a fix.