Loctax - Investigating Website incident – Incident details

Investigating Website incident

Resolved
Partial outage
Started 8 months agoLasted 4 minutes

Affected

Website

Partial outage from 9:53 PM to 9:57 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Investigating
    Investigating

    We are currently investigating this incident.